import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "night (.*)|Total(.*)";
final String string = "<strong class=\"price scarcity_color sr_gs_rackrate_price\n"
+ " anim_rack_rate \n"
+ "\" title=\"Price for 1 night £69\">\n"
+ "<b>\n"
+ "<span class=\"sr_gs_rackrate_total\">Total: </span>\n"
+ "£69\n"
+ "</b>\n"
+ "</strong>\n"
+ "<td class=\"totalPrice\" colspan=\"3\">\n"
+ "<div data-component=\"track\" data-hash=\"OLNYSRfCbdWGffSRe\" data-stage=\"1\" data-track=\"view\"></div>\n"
+ "Total: £145\n"
+ "</td>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}