$re = '/<(.*)>; *rel="(.*)"/iU';
$str = '<http://feeds.mashable.com/Mashable>; rel="self", <http://pubsubhubbub.appspot.com/>; rel="hub"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);