using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.*)>; *rel=""(.*)""";
string input = @"<http://feeds.mashable.com/Mashable>; rel=""self"", <http://pubsubhubbub.appspot.com/>; rel=""hub""";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}