package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?iU)<(.*)>; *rel="(.*)"`)
var str = `<http://feeds.mashable.com/Mashable>; rel="self", <http://pubsubhubbub.appspot.com/>; rel="hub"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}