re = /(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}\+\d{4})/
str = '\'{"roomMappings":{"createdAt":"2015-04-10T00:32:04+0000","channelOffers":[]}}\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end