const regex = /(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}\+\d{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}:\\d{2}\\+\\d{4})', '')
const str = `'{"roomMappings":{"createdAt":"2015-04-10T00:32:04+0000","channelOffers":[]}}'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}