$re = '/(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}\+\d{4})/';
$str = '\'{"roomMappings":{"createdAt":"2015-04-10T00:32:04+0000","channelOffers":[]}}\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);