import Foundation
let pattern = #"href="([^>]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a id="link-1" href="/regexp-one">正则文章合集(All In One)</a>
<a id="link-2" href="/my-regexp">正则入门教程</a>
<a id="link-3" href="/deep-regexp">正则高级教程</a>
<a id="link-4" href="/regexp-lookaround">正则环视详解</a>
<a id="link-5" href="/php-curl">PHP cURL应用</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://www.zjmainstay.cn$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)