re = /href="([^>]+)"/
str = '<a id="link-1" href="/regexp-one">正则文章合集(All In One)</a>
<a id="link-2" href="/my-regexp">正则入门教程</a>
<a id="link-3" href="/deep-regexp">正则高级教程</a>
<a id="link-4" href="/regexp-lookaround">正则环视详解</a>
<a id="link-5" href="/php-curl">PHP cURL应用</a>'
subst = 'http://www.zjmainstay.cn$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result