# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=\"([^>]+)\""
test_str = ("<a id=\"link-1\" href=\"/regexp-one\">正则文章合集(All In One)</a>\n"
"<a id=\"link-2\" href=\"/my-regexp\">正则入门教程</a>\n"
"<a id=\"link-3\" href=\"/deep-regexp\">正则高级教程</a>\n"
"<a id=\"link-4\" href=\"/regexp-lookaround\">正则环视详解</a>\n"
"<a id=\"link-5\" href=\"/php-curl\">PHP cURL应用</a>")
subst = "http://www.zjmainstay.cn$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.