re = /(@url)([\s]=[\s]*)(?:')(.*)(?:')(?:;)/
str = '@url = \'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer\';
@header.add(\'secret\',\'koutty2222Efdxaaalghteqjkhy\')
var @collectionitems = @collectionitem(\'value1\')
var @timeItems = {20221003, 20221004}
@block.loop(@item1 in @collectionitems, @item2 in @timeItems)
@block.end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end