$re = '/(@url)([\s]=[\s]*)(?:\')(.*)(?:\')(?:;)/';
$str = '@url = \'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer\';
@header.add(\'secret\',\'koutty2222Efdxaaalghteqjkhy\')
var @collectionitems = @collectionitem(\'value1\')
var @timeItems = {20221003, 20221004}
@block.loop(@item1 in @collectionitems, @item2 in @timeItems)
@block.end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);