package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(@url)([\s]=[\s]*)(?:')(.*)(?:')(?:;)`)
var str = `@url = 'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer';
@header.add('secret','koutty2222Efdxaaalghteqjkhy')
var @collectionitems = @collectionitem('value1')
var @timeItems = {20221003, 20221004}
@block.loop(@item1 in @collectionitems, @item2 in @timeItems)
@block.end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}