$re = '/\[.*\] (.*)(?::| (?:[\u203a\u00BB>])) (.*)/';
$str = '[real] among > us';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);