package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[.*\] (.*)(?::| (?:[\u203a\u00BB>])) (.*)`)
var str = `[real] among > us`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}