const regex = /\[.*\] (.*)(?::| (?:[\u203a\u00BB>])) (.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[.*\\] (.*)(?::| (?:[\\u203a\\u00BB>])) (.*)', '')
const str = `[real] among > us`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}