re = /s/
str = 'need to implement method call
line.append(string)
something.something(optional)
function call
print()
print("hello")
func (weird, func, call)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end