#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "s"
Local $sString = "need to implement method call" & @CRLF & _
"line.append(string)" & @CRLF & _
"something.something(optional)" & @CRLF & _
"function call" & @CRLF & _
"print()" & @CRLF & _
"print("hello")" & @CRLF & _
"func (weird, func, call)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")