$re = '/s/';
$str = 'need to implement method call
line.append(string)
something.something(optional)
function call
print()
print("hello")
func (weird, func, call)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);