// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(http(s)?:\/\/)((www\.)?[steamcommunity]+\.)+[\w-]+(\/profiles\/7656[0-9]{13}\/?)$").unwrap();
let string = "https://steamcommunity.com/profiles/76561197963701815
http://steamcommunity.com/profiles/76561197963701815
https://www.steamcommunity.com/profiles/76561197963721411/
http://www.steamcommunity.com/profiles/76561197863721421/
http://steamcommunity.com/id/AyyDrWhat/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}