$re = '/^(http(s)?:\/\/)((www\.)?[steamcommunity]+\.)+[\w-]+(\/profiles\/7656[0-9]{13}\/?)$/im';
$str = 'https://steamcommunity.com/profiles/76561197963701815
http://steamcommunity.com/profiles/76561197963701815
https://www.steamcommunity.com/profiles/76561197963721411/
http://www.steamcommunity.com/profiles/76561197863721421/
http://steamcommunity.com/id/AyyDrWhat/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);