using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http(s)?:\/\/)((www\.)?[steamcommunity]+\.)+[\w-]+(\/profiles\/7656[0-9]{13}\/?)$";
string input = @"https://steamcommunity.com/profiles/76561197963701815
http://steamcommunity.com/profiles/76561197963701815
https://www.steamcommunity.com/profiles/76561197963721411/
http://www.steamcommunity.com/profiles/76561197863721421/
http://steamcommunity.com/id/AyyDrWhat/";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}