re = /(?=query|mutation).+?(?=query|mutation|\Z)/m
str = 'query get_telemetry (name: String, start_time: String, end_time: String) {
parameters:satelliteOperatorInteractionParameters(name: $name) {
edges {
node {
name
path
states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {
edges {
node {
timestamp
calibrated_value:calibratedValue
}
}
}
}
}
}
}
mutation get_all_possible_parameters {
parameters:satelliteOperatorInteractionParameters {
edges {
node {
path
}
}
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end