const regex = new RegExp('(?=query|mutation).+?(?=query|mutation|\\Z)', 'gms')
const str = `query get_telemetry (name: String, start_time: String, end_time: String) {
parameters:satelliteOperatorInteractionParameters(name: \$name) {
edges {
node {
name
path
states(timestamp_Gte: \$start_time, timestamp_Lte: \$end_time) {
edges {
node {
timestamp
calibrated_value:calibratedValue
}
}
}
}
}
}
}
mutation get_all_possible_parameters {
parameters:satelliteOperatorInteractionParameters {
edges {
node {
path
}
}
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}