using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=query|mutation).+?(?=query|mutation|\Z)";
string input = @"query get_telemetry (name: String, start_time: String, end_time: String) {
parameters:satelliteOperatorInteractionParameters(name: $name) {
edges {
node {
name
path
states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {
edges {
node {
timestamp
calibrated_value:calibratedValue
}
}
}
}
}
}
}
mutation get_all_possible_parameters {
parameters:satelliteOperatorInteractionParameters {
edges {
node {
path
}
}
}
}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}