re = /(?# Patrón de nombre multivariado)
\bJorge\s+((Alberto|A\.?)\s+)?\/?(?P<Apellido>G[óo]mez)(\s+(Prada|P\.?))?\b/ix
str = '(1)Jorge Alberto Gómez Prada = (2)Jorge Gómez = (3)Jorge A Gómez = (4)Jorge A. Gómez P.
(5)(Jorge GOMEZ P.a) ... (6)Alberto jorge GÓMEZ (7)Jorge /Gómez
(8)>>Jorge A
Gómez P<< (9)Jorge Gómez Pradas (10)JJorge Gómez (11) Luis Jorge Gómeza'
subst = 'Amparo \\g<Apellido>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result