import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?# Patrón de nombre multivariado)\n"
+ "\\bJorge\\s+((Alberto|A\\.?)\\s+)?/?(?P<Apellido>G[óo]mez)(\\s+(Prada|P\\.?))?\\b";
final String string = "(1)Jorge Alberto Gómez Prada = (2)Jorge Gómez = (3)Jorge A Gómez = (4)Jorge A. Gómez P. \n"
+ "(5)(Jorge GOMEZ P.a) ... (6)Alberto jorge GÓMEZ (7)Jorge /Gómez\n"
+ "(8)>>Jorge A\n"
+ "Gómez P<< (9)Jorge Gómez Pradas (10)JJorge Gómez (11) Luis Jorge Gómeza";
final String subst = "Amparo \\g<Apellido>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}