# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?# Patrón de nombre multivariado)
\bJorge\s+((Alberto|A\.?)\s+)?\/?(?P<Apellido>G[óo]mez)(\s+(Prada|P\.?))?\b/Amparo \g<Apellido>/gix;t' <<< "(1)Jorge Alberto Gómez Prada = (2)Jorge Gómez = (3)Jorge A Gómez = (4)Jorge A. Gómez P.
(5)(Jorge GOMEZ P.a) ... (6)Alberto jorge GÓMEZ (7)Jorge /Gómez
(8)>>Jorge A
Gómez P<< (9)Jorge Gómez Pradas (10)JJorge Gómez (11) Luis Jorge Gómeza"