$re = '/^\+421[0-9]{9}$/';
$str = '+421999999980';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);