const regex = /^\+421[0-9]{9}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+421[0-9]{9}$', '')
const str = `+421999999980`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}