package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\+421[0-9]{9}$`)
var str = `+421999999980`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}