import Foundation
let pattern = #"^module.(?<module_name>.*)\.(?<module_subname>.*)\.(?<module_item>[a-z|\_|\-|\[|\]|0-9]*[a-z|\.|\[|0-9\]])\:\ (?<action_type>[A-Z|a-z|\ ]*(?<action_status>\.\.\.\ |complete))|\ after\ (?<complete_time>[0-9]*s)|\((?<elapsed_time>[0-9]*s)\ elapsed\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
module.indexer.aws_autoscaling_group.indexer.0: Still creating... (30s elapsed)
module.indexer.aws_autoscaling_group.indexer.2: Still creating... (30s elapsed)
module.indexer.aws_autoscaling_group.indexer.1: Still creating... (30s elapsed)
module.indexer.aws_autoscaling_group.indexer.0: Still creating... (40s elapsed)
module.indexer.aws_autoscaling_group.indexer.2: Still creating... (40s elapsed)
module.indexer.aws_autoscaling_group.indexer.1: Still creating... (40s elapsed)
module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)
module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)
module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.indexer.aws_autoscaling_group.indexer[0]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-78aba033)
module.indexer.aws_autoscaling_group.indexer[1]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-08397f55)
module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s
module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s
module.indexer.null_resource.indexer_asg[1]: Destruction complete after 0s
module.indexer.null_resource.indexer_asg[2]: Destruction complete after 0s
module.security_groups.aws_security_group_rule.public_search_head_vault: Destruction complete after 1s
module.security_groups.aws_security_group_rule.private_sg_self_rule_out[2]: Destruction complete after 1s
module.security_groups.aws_security_group_rule.private_sg_ldap_outbound[0]: Destroying... (ID: sgrule-1706144597)
module.indexer.aws_autoscaling_attachment.hec[1]: Destroying... (ID: sre-sandbox - indexer - subnet-08397f55-20190901000149529200000006)
module.security_groups.aws_security_group_rule.private_sg_port443: Destroying... (ID: sgrule-2181904703)
module.security_groups.aws_security_group_rule.private_sg_self_rule_out[3]: Destruction complete after 1s
module.indexer.aws_ssm_parameter.facts: Destroying... (ID: /dev/facts/stack/sre-sandbox/indexer)
module.indexer.dyn_node.inputs-dns[4]: Destruction complete after 6s
module.security_groups.aws_security_group_rule.indexer_self[1]: Destroying... (ID: sgrule-2553743418)
module.indexer.aws_ssm_parameter.facts: Destruction complete after 0s
module.indexer.aws_autoscaling_attachment.hec[1]: Destruction complete after 1s
module.security_groups.aws_security_group_rule.private_sg_self_rule[0]: Destroying... (ID: sgrule-262603171)
module.sh1.aws_autoscaling_group.search_head: Destroying... (ID: sh1 - sre-sandbox - search-head)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)