use strict;
my $str = 'module.indexer.aws_autoscaling_group.indexer.0: Still creating... (30s elapsed)
module.indexer.aws_autoscaling_group.indexer.2: Still creating... (30s elapsed)
module.indexer.aws_autoscaling_group.indexer.1: Still creating... (30s elapsed)
module.indexer.aws_autoscaling_group.indexer.0: Still creating... (40s elapsed)
module.indexer.aws_autoscaling_group.indexer.2: Still creating... (40s elapsed)
module.indexer.aws_autoscaling_group.indexer.1: Still creating... (40s elapsed)
module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)
module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)
module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)
module.indexer.aws_autoscaling_group.indexer[0]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-78aba033)
module.indexer.aws_autoscaling_group.indexer[1]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-08397f55)
module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s
module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s
module.indexer.null_resource.indexer_asg[1]: Destruction complete after 0s
module.indexer.null_resource.indexer_asg[2]: Destruction complete after 0s
module.security_groups.aws_security_group_rule.public_search_head_vault: Destruction complete after 1s
module.security_groups.aws_security_group_rule.private_sg_self_rule_out[2]: Destruction complete after 1s
module.security_groups.aws_security_group_rule.private_sg_ldap_outbound[0]: Destroying... (ID: sgrule-1706144597)
module.indexer.aws_autoscaling_attachment.hec[1]: Destroying... (ID: sre-sandbox - indexer - subnet-08397f55-20190901000149529200000006)
module.security_groups.aws_security_group_rule.private_sg_port443: Destroying... (ID: sgrule-2181904703)
module.security_groups.aws_security_group_rule.private_sg_self_rule_out[3]: Destruction complete after 1s
module.indexer.aws_ssm_parameter.facts: Destroying... (ID: /dev/facts/stack/sre-sandbox/indexer)
module.indexer.dyn_node.inputs-dns[4]: Destruction complete after 6s
module.security_groups.aws_security_group_rule.indexer_self[1]: Destroying... (ID: sgrule-2553743418)
module.indexer.aws_ssm_parameter.facts: Destruction complete after 0s
module.indexer.aws_autoscaling_attachment.hec[1]: Destruction complete after 1s
module.security_groups.aws_security_group_rule.private_sg_self_rule[0]: Destroying... (ID: sgrule-262603171)
module.sh1.aws_autoscaling_group.search_head: Destroying... (ID: sh1 - sre-sandbox - search-head)
';
my $regex = qr/^module.(?<module_name>.*)\.(?<module_subname>.*)\.(?<module_item>[a-z|\_|\-|\[|\]|0-9]*[a-z|\.|\[|0-9\]])\:\ (?<action_type>[A-Z|a-z|\ ]*(?<action_status>\.\.\.\ |complete))|\ after\ (?<complete_time>[0-9]*s)|\((?<elapsed_time>[0-9]*s)\ elapsed\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}