#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^module.(?<module_name>.*)\.(?<module_subname>.*)\.(?<module_item>[a-z|\_|\-|\[|\]|0-9]*[a-z|\.|\[|0-9\]])\:\ (?<action_type>[A-Z|a-z|\ ]*(?<action_status>\.\.\.\ |complete))|\ after\ (?<complete_time>[0-9]*s)|\((?<elapsed_time>[0-9]*s)\ elapsed\)"
Local $sString = "module.indexer.aws_autoscaling_group.indexer.0: Still creating... (30s elapsed)" & @CRLF & _
"module.indexer.aws_autoscaling_group.indexer.2: Still creating... (30s elapsed)" & @CRLF & _
"module.indexer.aws_autoscaling_group.indexer.1: Still creating... (30s elapsed)" & @CRLF & _
"module.indexer.aws_autoscaling_group.indexer.0: Still creating... (40s elapsed)" & @CRLF & _
"module.indexer.aws_autoscaling_group.indexer.2: Still creating... (40s elapsed)" & @CRLF & _
"module.indexer.aws_autoscaling_group.indexer.1: Still creating... (40s elapsed)" & @CRLF & _
"module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)" & @CRLF & _
"module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)" & @CRLF & _
"module.cluster_master.aws_autoscaling_group.cluster_master: Creation complete after 40s (ID: sre-sandbox - cluster-master)" & @CRLF & _
"module.sh1.aws_autoscaling_group.search_head: Creation complete after 40s (ID: sh1 - sre-sandbox - search-head)" & @CRLF & _
"module.indexer.aws_autoscaling_group.indexer[0]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-78aba033)" & @CRLF & _
"module.indexer.aws_autoscaling_group.indexer[1]: Creation complete after 41s (ID: sre-sandbox - indexer - subnet-08397f55)" & @CRLF & _
"module.kms_key.aws_kms_key.stack_key: Destruction complete after 22s" & @CRLF & _
"module.iam_profile.aws_iam_role.stack_iam_role: Destruction complete after 1s" & @CRLF & _
"module.indexer.null_resource.indexer_asg[1]: Destruction complete after 0s" & @CRLF & _
"module.indexer.null_resource.indexer_asg[2]: Destruction complete after 0s" & @CRLF & _
"module.security_groups.aws_security_group_rule.public_search_head_vault: Destruction complete after 1s" & @CRLF & _
"module.security_groups.aws_security_group_rule.private_sg_self_rule_out[2]: Destruction complete after 1s" & @CRLF & _
"module.security_groups.aws_security_group_rule.private_sg_ldap_outbound[0]: Destroying... (ID: sgrule-1706144597)" & @CRLF & _
"module.indexer.aws_autoscaling_attachment.hec[1]: Destroying... (ID: sre-sandbox - indexer - subnet-08397f55-20190901000149529200000006)" & @CRLF & _
"module.security_groups.aws_security_group_rule.private_sg_port443: Destroying... (ID: sgrule-2181904703)" & @CRLF & _
"module.security_groups.aws_security_group_rule.private_sg_self_rule_out[3]: Destruction complete after 1s" & @CRLF & _
"module.indexer.aws_ssm_parameter.facts: Destroying... (ID: /dev/facts/stack/sre-sandbox/indexer)" & @CRLF & _
"module.indexer.dyn_node.inputs-dns[4]: Destruction complete after 6s" & @CRLF & _
"module.security_groups.aws_security_group_rule.indexer_self[1]: Destroying... (ID: sgrule-2553743418)" & @CRLF & _
"module.indexer.aws_ssm_parameter.facts: Destruction complete after 0s" & @CRLF & _
"module.indexer.aws_autoscaling_attachment.hec[1]: Destruction complete after 1s " & @CRLF & _
"module.security_groups.aws_security_group_rule.private_sg_self_rule[0]: Destroying... (ID: sgrule-262603171)" & @CRLF & _
"module.sh1.aws_autoscaling_group.search_head: Destroying... (ID: sh1 - sre-sandbox - search-head)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")