const regex = /Your Updated Reservation Confirmation (?:#\s?)?\d+ at .+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Your Updated Reservation Confirmation (?:#\\s?)?\\d+ at .+', '')
const str = `Your Updated Reservation Confirmation # 68876759 at Holiday Inn Express.
Your Updated Reservation Confirmation at Holiday Inn Hotel & Suites - Confirmation # 64754230
Your Updated Reservation Confirmation at Crowne Plaza - Confirmation # 68003047`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}