#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Your Updated Reservation Confirmation (?:#\s?)?\d+ at .+"
Local $sString = "Your Updated Reservation Confirmation # 68876759 at Holiday Inn Express." & @CRLF & _
"" & @CRLF & _
"Your Updated Reservation Confirmation at Holiday Inn Hotel & Suites - Confirmation # 64754230" & @CRLF & _
"" & @CRLF & _
"Your Updated Reservation Confirmation at Crowne Plaza - Confirmation # 68003047"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")