import Foundation
let pattern = #"[\+]?\d{0,3}([(]?\d{3}[)]?[-.]?\d{3}[-.]?\d{2}[-.]?\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"984-169-3656 984.169.36.56 (984)-169-36-56 +5219841693656 +529841693656"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)