$re = '/[\+]?\d{0,3}([(]?\d{3}[)]?[-.]?\d{3}[-.]?\d{2}[-.]?\d{2})/';
$str = '984-169-3656 984.169.36.56 (984)-169-36-56 +5219841693656 +529841693656';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;