const regex = /[\+]?\d{0,3}([(]?\d{3}[)]?[-.]?\d{3}[-.]?\d{2}[-.]?\d{2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\+]?\\d{0,3}([(]?\\d{3}[)]?[-.]?\\d{3}[-.]?\\d{2}[-.]?\\d{2})', 'g')
const str = `984-169-3656 984.169.36.56 (984)-169-36-56 +5219841693656 +529841693656`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);