import Foundation
let pattern = #"\{\s*method: ?["'](\w+)["']\s*\};"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" { method: "GET" };"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{method: "$1", credentials: "same-origin"};"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)