using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\s*method: ?[""'](\w+)[""']\s*\};";
string substitution = @"{method: ""$1"", credentials: ""same-origin""};";
string input = @" { method: ""GET"" };";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}