$re = '/\{\s*method: ?["\'](\w+)["\']\s*\};/';
$str = ' { method: "GET" };';
$subst = "{method: \"$1\", credentials: \"same-origin\"};";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;