re = /^(?:(?P<protocol>.+):\/\/)?(?:(?P<sub>.+)\.)?(?P<domain>.+)\.(?P<tld>[a-zA-Z]+)(?P<path>\/(?:(?:.*?)(?:(?=\?)?))?)?(?P<query>\?.+?)?$/m
str = 'google.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end