const regex = new RegExp('^(?:(?P<protocol>.+)://)?(?:(?P<sub>.+)\\.)?(?P<domain>.+)\\.(?P<tld>[a-zA-Z]+)(?P<path>/(?:(?:.*?)(?:(?=\\?)?))?)?(?P<query>\\?.+?)?$', 'm')
const str = `google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}