$re = '/^(?:(?P<protocol>.+)://)?(?:(?P<sub>.+)\.)?(?P<domain>.+)\.(?P<tld>[a-zA-Z]+)(?P<path>/(?:(?:.*?)(?:(?=\?)?))?)?(?P<query>\?.+?)?$/m';
$str = 'google.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);