# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([\w\s]+)\|(?:[\d{2,4}\/]+)\|([\w\s]+)\|(\d+)\|(\d{5}-\d{3})\|([\w\s]+)$"
test_str = ("Nico Steppat|14/05/1977|Rua Buarque de Macedo|50|22222-222|Rio de Janeiro\n"
"Romulo Henrique|14/06/1993|Rua do Lins|120|12345-322|Rio de Janeiro\n"
"Leonardo Cordeiro|01/01/1995|Rua de Campo Grande|01|00001-234|Rio de Janeiro")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.