package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w\s]+)\|(?:[\d{2,4}\/]+)\|([\w\s]+)\|(\d+)\|(\d{5}-\d{3})\|([\w\s]+)$`)
var str = `Nico Steppat|14/05/1977|Rua Buarque de Macedo|50|22222-222|Rio de Janeiro
Romulo Henrique|14/06/1993|Rua do Lins|120|12345-322|Rio de Janeiro
Leonardo Cordeiro|01/01/1995|Rua de Campo Grande|01|00001-234|Rio de Janeiro`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}