import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w\\s]+)\\|(?:[\\d{2,4}\\/]+)\\|([\\w\\s]+)\\|(\\d+)\\|(\\d{5}-\\d{3})\\|([\\w\\s]+)$";
final String string = "Nico Steppat|14/05/1977|Rua Buarque de Macedo|50|22222-222|Rio de Janeiro\n"
+ "Romulo Henrique|14/06/1993|Rua do Lins|120|12345-322|Rio de Janeiro\n"
+ "Leonardo Cordeiro|01/01/1995|Rua de Campo Grande|01|00001-234|Rio de Janeiro";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}