$re = '/\w{4} \d{2} \w{5} \d{2} \w{3} \d{4}/m';
$str = 'Hôm nay, ngày 04 tháng 08 năm 2020 (“Ngày Ký”), chúng tôi gồm có:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);