using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w{4} \d{2} \w{5} \d{2} \w{3} \d{4}";
string input = @"Hôm nay, ngày 04 tháng 08 năm 2020 (“Ngày Ký”), chúng tôi gồm có:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}